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You will need: 

· a basic understanding of how Web sites work

· FrontPage  installed on your computer

1) Open Windows Explorer:

2) Find your H: drive and click  into H:\inetpub
3) This is where you would store any web pages that you want available for browsing from anywhere on the Internet

4) If someone wanted to browse a page in that folder the URL will be
http://students.uwsp.edu/yourLogonName/NameOfThePage.htm
Start FrontPage Editor 

1. Left click Start button, slide to Programs, and select Microsoft FrontPage Editor.

Open an HTML file. 

To create a new document 

If you are creating a new file from scratch, begin typing or pasting text into the blank document on your screen. 

1. Choose File > New > Page from the menu bar. 

2. Select Normal Page
To open an existing file or template that you have downloaded

1. Choose File > Open, then select your file.
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Orient yourself to the menus and buttons. 
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Start typing some lines with your name and a few sentences about yourself or whatever.

Type  a couple of very short paragraphs.

Experiment with the formatting buttons.

Save your work. 

Save your work often so that if you make a mistake or your computer freezes, you can always go back to a previous version of your work.

1. Choose File > Save from the menu bar. 

2. Double click your folder in the folder list and type index.htm as the name of your document

3. Click the OK button.

4. If you have any images it will list the embedded files to save. Click OK
5. It is now stored and available at 

http://students.uwsp.edu/yourLogonname/index.htm

Example:    http://students.uwsp.edu/bfavr004/index.htm   (hypothetical- Brett is not enrolled here)
To use a page from your web browser
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If you know the URL you can use any existing Web page as a template by opening the page via the Web Browser button on the File > Open dialog box

Edit Text with Microsoft FrontPage 

Change your text alignment. 

1. Use the mouse to highlight the text you want to realign. 

2. From the menu bar, choose Format > Paragraph. 

3. Choose Left, Right, or Center from the Paragraph Alignment pull-down menu in the Paragraph Properties dialog box that appears. 

4. Click OK
You can also change text alignment by clicking one of the three Alignment buttons

You may find some differences between Word and FrontPage with regard to alignment of table cells and images.  Periodically check how it looks in the browser.

 Change the look of your font. 

1. Use the mouse to highlight the text you want to change. 

2. On the button bar, click the B button for bold, the I button for italic, or the U button for underlined text. 

3. If you change your mind, press the B, I, or U button again to undo the formatting.

Save your work frequently! If you are working from a template, it is best to save to a different file name than the original template, preferably one that will be meaningful to you.

 Choose a different font. 

1. Use the mouse to highlight the text you want to change. 

2. From the menu bar, choose Format > Font. 

3. Select the Font tab (may already be selected). 

4. Choose a font name from the list of options under 'Font:'. 

5. You can change the style, size, and color of the font here as well.

For maximum control over how your pages look, use only the most universal fonts such as 

Times New Roman

formal, business-like font
Arial



casual, more readable font

Courier New 

Courier New is a non-proportional font. 

Use Courier only when you have data that needs to line up

While you may use any font installed on your computer, people viewing your page may not have the same fonts on their computers. In this case, their computers will substitute another font for the one you used, changing the look of your page.

Create a bulleted or numbered list. 

1. Choose Format > Bullets and Numbering . . . from the menu bar 

2. Choose the Bulleted or Numbers tab. 

3. Select the type of bullets or numbers from the options available. 

4. Click OK. 

You can now type or paste text for your first list item. Hit the 'Return' or 'Enter' key on your keyboard to insert a new bullet point or number.
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Fancy bullets are separate images that must be migrated with the HTML page if the page is moved to a different server or copied to a backup disk.  FRONTPAGE Explorer will take care of this if you don't "accidentally" clean up by deleting images.

Use Paragraph styles

Use the 
Change Style 
drop-down menu 
to change the paragraph style of the selection in the FrontPage Editor.

If the page uses a theme, contains an embedded style sheet, or is linked to an external style sheet, the paragraph styles listed in the drop-down are defined by the theme or style sheet. 

Viewing the page with the Normal/HTML/Preview Tabs


Try the tabs in the bottom left corner of the FRONTPAGE Editor window.

· Normal tab is the view you get when you are editing

· HTML tab allows you to look at and edit the HTML code directly.  This is a good way to debug problems with image names or bad hyperlink references.

· Preview tab quickly previews the current page in the FrontPage Editor.  It uses Internet Explorer to do it.

You can use it to test your hyperlinks and see how your images and tables look as they are the most likely problem areas.

Checking the page in Netscape

If the page is already on a web server you can also open and check the page in Netscape as you go along by typing in the page's URL.  To check your changes as you go, you will need to:

1. Save the changes; this updates the web server's copy of your changed page

2. Type in the URL 

Example: http://students.uwsp.edu/yourLogonName/index.htm

3. You can leave the Netscape browser open on the Windows taskbar and check it periodically as you make changes.  You will need to click the Reload button after each "Save" so that the browser requests a 'new' copy of your page from the Web server.
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I strongly suggest you save your web page frequently and either preview it or look at it through a web browser as you develop it.

Insert Images with Microsoft FrontPage 

You will need: 

· an HTML document or template, open in FrontPage , and 

· images saved as .gif or .jpg  files.

Decide where to place the image. 

Images can be inserted almost anywhere on a page, even inside a table. Position the cursor where you would like the image to appear and click once.

  Insert the image. 

1. From the menu bar, choose Insert > Image. Or, on the toolbar, click the image button (with a picture of a mountain peak). 

2. Find your image file in the Select File dialog box that appears, and select it by clicking on it once. 

3. Click OK.

 Move the image or change its dimensions. 

1. Select the image by clicking on it once. Eight tiny squares appear which serve as 'handles' that can be dragged in various directions to change image dimensions. 

2. To move the image to a new location without changing its dimensions, select the image and drag it from its center point to its new location.

 Change image properties. 

1. From the menu bar, choose Edit > Image Properties. 

2. Select the Appearance tab. 

· Alignment determines how text will be aligned in relation to the image.

· Horizontal Spacing and Vertical Spacing determine how close adjacent page elements (such as other images or text) will be to the image.

· Border Thickness changes the thickness of a line-border to the image.

· Specify Size allows you to adjust the image size, either in absolute measurement (in pixels) or as a percentage of the height and width of the browser window that displays it.

· When adjusting the absolute (pixel) size of an image, make sure the Keep Aspect Ratio' box is checked. This way, as you change one dimension, the other dimension changes proportionally and prevents image distortion. 

FrontPage  provides only basic tools for image formatting. Fine-tune photographs and images for the Web with an image-editing program (such as MS Photo Editor or Adobe PhotoShop) before inserting them into your Web page. 

Using Photo Editor to adjust images

Use MS PhotoEditor to do simple adjustments such as resizing, cropping, and converting images to compressed formats. It is very important to reduce the image size so as to minimize the download time for people looking at your web pages. (PhotoEditor is available in most computer labs and on most faculty computers, usually under Accessories  or Microsoft Office.)

This shows the file size differences of a photo called "golden"

· using different image formats

· resizing the original image by 50%

By far the smallest at 30Kb is the 50_golden.jpg file.

Change the image format in PhotoEditor

1. Start MS PhotoEditor.  Try 
Start > Programs >Accessories > PhotoEditor  or
Start > Programs >MS Office > PhotoEditor

2. Open the original golden.tif file in PhotoEditor.

3. Select File > Save As
4. Select from Save As Type dropdown list : JPEG filter (.jpg)
Resize the image
5. Now resize the photo by 50 percent by selecting Image > Resize
6. In the Width:       % text box change the text from 100% to 50%. 

Note that the height automatically changes to 50% also. This prevents distortion of the image.

7. Click Ok and then Save the change.

Crop the image

8. Crop the image by clicking on the Select button and then moving (not dragging) the cursor to the "corner" of the proposed cropping. 

9. Click and drag the select "box" to the opposite corner of the desired cropped picture and release the mouse button

10. From the Menu select Image > Crop.  The measurements are ready to go. Click OK.

11. If you're satisfied with the cropped picture Save it, otherwise press the edit Undo button and try again.

Insert a Hyperlink with Microsoft FrontPage 

You will need: 

· an HTML document or template, opened in FrontPage, that includes text or graphic elements, and 

· a list of URLs to which you would like to link.

Select what you want to turn into a hyperlink. 

With the mouse, highlight the text or click on the image that you will turn into a hyperlink.

 Select the Links tool. 

On the toolbar, click the button with a picture of a globe and chain links on it. Alternatively, from the menu bar, choose Insert > Hyperlink . . .

 Specify the type and location of your link. 

The 'Create Hyperlink' dialog box defaults to a URL that begins with 'http://' — in other words, a Web page. You can type or paste the entire URL of your link in the 'URL:' box provided. FrontPage lets you choose several other types of links:

Link to a file on your computer 

· Click the icon of a folder with a magnifying glass and then navigating to the correct file. 

· Link to an email address by clicking the envelope icon and typing or pasting an email address. 

· Simultaneously create and link to a new page by clicking the blank page icon. 

· Once the link is entered, click OK.

Insert external links

Inserting external links can be tedious. The fastest possible way is to have all URLs stored in electronic format, such as bookmark/favorites files or text files, so you can quickly copy and paste into your document. The copy/paste method also tends to be more accurate than typing and saves you time.

Check the links. 

· One tiny typo on a link will break it. It is a good idea to test all the links on your page by opening the page with a Web browser to make sure they work. The Web constantly changes, so links should be checked regularly.

BONUS!!!

Create a thumbnail image

A thumbnail image is a small version of an image on a page. that contains a hyperlink to a full-size version of the same image.

1
In the FrontPage Editor, select the image.

2
On the Tools menu, choose AutoThumbnail.

FrontPage creates the thumbnail image, inserts it in place of the larger image, and creates a hyperlink to the full-sized image from the thumbnail image.
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In your folder you will now see two files of your photo image.  The web page will display the thumbnail image on the browser view of the page.  If the user wants to see the larger version then he/she clicks on it and the page links to the original photo image and displays it.

Example: http://www.uwsp.edu/cis/mstern/101/africa/tanzania.htm 

This is a great way to display a gallery of photos without driving the Internet user crazy.

Some Graphics resources:

http://dir.yahoo.com/Arts/Visual_Arts/Computer_Generated/Graphics/ 

More Web tools: A great site with many Web page design tools and style links, created by Roger Bullis in Communications Division:  Comm 304 - Class Resources on the Web

Change Attributes with Microsoft FrontPage 

Orient yourself to the Properties options. 

From the menu bar, choose File > Page Properties. Notice the different tabs labeled 'General', 'Background', 'Margins', 'Custom', and 'Language'. Of these, you'll find 'General' and 'Background' particularly useful.

It is easy to get 'Page Properties' and 'Page Setup' confused, especially since 'Page Properties' in FrontPage is similar to 'Page Setup' in Microsoft Word. 'Page Setup' in FrontPage  deals with things you are unlikely to use in Web pages, such as headers and footers.

 Change the background and text colors. 

Under the 'Background' tab, make sure 'Specify Background and Colors' is selected. 

To specify a repeating image as your page background, select 'Background Image' and type or navigate to the image you want. 

Color palette pull-down menus allow you to set the background color of your page, the color of regular text, and various link colors: 

· Hyperlink: This specifies the color of clickable hyperlinks on your page. The default color is blue. 

· Visited Hyperlink: This specifies the color for hyperlinks that have already been visited. The default is purple.

· Active Hyperlink: This specifies the color for hyperlinks during the few moments while the browser is looking for the linked location. The default is red. 

Background and text colors hints

· When in doubt, use a solid background color. Background graphics are very often distracting and slow to download, and they make text more difficult to read. 

· Make sure the text color and background colors are high-contrast (dark text with a light background). This is particularly important if students will be printing from your site. 

· Web users learn to look for blue when they look for hyperlinks. Using other colors for links may make it difficult to navigate through your site.

Create Tables with Microsoft FrontPage 

Decide what you want the table to do. 

Tables on the Web fall into two categories: data display and page layout. Although the method for making both kinds of tables is the same, it helps to know what kind of table you want before you begin building it.

· Tables are commonly used to display or organize data. Data tables act as discrete elements of a Web page, much like tables inserted into word processing programs. 

· Tables can also serve page layout purposes. Table columns and rows can be used to control where text and graphics are placed with more precision than is typical with simple HTML, which is limited in its ability to handle multiple spaces and tabs.

Create and insert a table. 

Position your cursor where you want the table to appear and click once. 

From the menu bar, choose Table > Insert Table.

Decide what you want your table to look like. 

Insert Table dialog box 

· Rows: Specify the number of horizontal rows you would like your table to have. 

· Columns: Specify the number of vertical columns you would like your table to have.

· Alignment: Choose whether you want your table centered, on the left side of the page, or on the right side of the page.

· Border Size: Specify the thickness of your table's outside border. 
A border size of 0 will give you a table with no visible gridlines. This kind of table can be used very effectively for page layout.

· Cell Padding: This is the space between the gridlines of the table (invisible or visible) and the contents of its cells. 

· Cell Spacing: This specifies how thick the grid lines of the table cells will be.

· Width: Tables stretch to accommodate whatever you put in them (graphics, text, etc.) unless you specify a width for them.

· Width in percent means percent of the page, regardless of what size the page is on any viewer's screen. I recommend that you use this option.
· Width in pixels is absolute. The table will be, say, 400 pixels wide regardless of the size of the browser window or monitor.

Different monitors have different numbers of pixels and this will affect the amount of a table that can be viewed on the screen. An old monitor, for example, will not be able to display more than 640 pixels horizontally and 480 pixels vertically. Some of this space will be used up by the browser itself. As a general rule, tables should not be more than 550 pixels wide.

 Add your content. 

When you are finished setting up your table, click OK and fill the cells with your content by clicking on a cell and typing or pasting text or images.

 If you change your mind about how you want your table to look, try the following: click the mouse cursor somewhere inside the table, then choose Table > Table Properties (or Cell Properties) from the menu bar and change table attributes. 

Add more rows or columns to your table. 

· Decide where you want to add a row or column and click inside one of the table cells.

· Choose Table > Insert Rows or Columns . . . from the menu bar. 

· Select the appropriate button for Columns or Rows. 

· Specify the number of columns or rows you want to add. 

· Depending on whether you are adding columns or rows, choose positioning above, below, to the left, or to the right of your cursor location. 

· Click OK.

Save your file to the server

HTML you should know:

About hyperlinks

Hyperlink reference to a Web page

<a href=”http://www.uwsp.edu/cis/mstern/101/index.htm ">Class Syllabus</a>

or 

<a href="    .........   ">              The HTML code that indicates a hyperlink

http://www.uwsp.edu/cis/mstern/syllabus.htm
This is an absolute reference because it gives the full address path to the web document..

<a href="332syllabus.htm">Class Syllabus</a>

This would be a relative reference since it does not give the path.  In that case the browser assumes the linked file is in the same folder as the web page.

Class Syllabus</a>  

The phrase that is displayed on the Web page. The user will click on it to initiate the link.
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